Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h d
e l
l r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h !
e d
l l
lowor

题目大意:给出一串字符串,将其按照U形打印出来。要求尽量像正方形,而且宽不小于高。

分析:首先需要确定宽和高的长度。经过手动模拟,发现所有字符串s可以按长度对3取余分为三类:余数为0、余数为1、余数为2。当长度为3 * n时(余数为0),高为n,宽为n+2;当长度为3 * n - 2(余数为1)时,高和宽都是n;当长度为3 * n - 1(余数为2)时,高为n,宽为n+1。用cnt控制输出字符即可,每一行第一个字符的小标和最后一个字符的下标加起来为length-1(length为字符串长度)。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include<iostream>
using namespace std;
int main(){
int height,width,length,cnt=0;
string s;
cin >> s;
length = s.size();
if (length % 3 == 0){
height = length / 3 ;
width = length / 3 + 2;
}
else if (length % 3 == 1){
height = ( length + 2 ) / 3;
width = ( length + 2 ) / 3;
}
else {
height = (length + 1) / 3;
width = (length + 1) / 3 + 1;
}
for (int i=0;i<height;i++){
if (i != height - 1){
cout << s[cnt];
for (int j=0;j<width-2;j++) cout << " ";
cout << s[length-cnt-1];
cnt++;
cout << endl;
}
else{
for (int j=0;j<width;j++)
cout << s[cnt++];
}
}
return 0;
}
Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input:
  4. 4. Sample Output: